Amazon Seller Central connection keeps expiring immediately after reconnection

Incident Report for Zapier

Resolved

The deployed fix has resolved the issue and we no longer see authorizations being disconnected.

If you have any questions, you can contact our support team: https://zapier.com/app/get-help.
Posted Aug 11, 2025 - 11:08 PDT

Monitoring

We have released a fix for Amazon Seller Central accounts getting disconnected immediately after reconnecting. We'll continue to monitor the fix to ensure no other issues pop up.

If you continue to run into issues, please reach out to our Support team: https://zapier.com/app/get-help
Posted Aug 11, 2025 - 10:56 PDT

Investigating

We are looking into issues related to Amazon Seller Central accounts getting disconnected immediately after reconnecting.

If you are running into this issue, please reach out to our support team: https://zapier.com/app/get-help
Posted Aug 11, 2025 - 09:43 PDT