Zapier.com pages slow to load
Incident Report for Zapier
Resolved
This incident has been resolved.

During this incident, there was no data loss and all services are now functioning as expected. We appreciate your patience and apologize for any inconvenience this may have caused.

If you encounter any issues or have further questions, please reach out to our Support Team: https://zapier.com/app/get-help
Posted May 18, 2023 - 17:29 PDT
Monitoring
At 15:03 UTC, our team identified an issue with Zapier.com pages loading slowly and some potential issues with logging into the site.

We've implemented a fix to address the issue and are currently monitoring the situation. You should be able to use Zapier.com as expected.

We'll continue to keep an eye on the situation and provide updates as necessary.

If you have any questions or need assistance, please reach out to our Support Team: https://zapier.com/app/get-help
Posted May 18, 2023 - 09:17 PDT
Investigating
We're currently investigating an issue where Zapier pages are slow to load and Webhook Triggers may be slow to execute. Unfortunately, there is no known workaround at this time.

The incident started today at 15:03 UTC. We're actively working on identifying the cause and finding a solution. We'll update the StatusPage as soon as we have more information or an estimated resolution time.

Please be assured that no data loss is expected as a result of this incident. We appreciate your patience while we work to resolve the issue. If you need assistance, please reach out to our Support Team: https://zapier.com/app/get-help
Posted May 18, 2023 - 08:42 PDT
Monitoring
At 15:03 UTC, our team identified an issue with Zapier.com pages loading slowly and some potential issues with logging into the site.

We've implemented a fix to address the issue and are currently monitoring the situation. You should be able to use Zapier.com as expected.

We'll continue to keep an eye on the situation and provide updates as necessary.

If you have any questions or need assistance, please reach out to our Support Team: https://zapier.com/app/get-help
Posted May 18, 2023 - 08:05 PDT
This incident affected: Website.