Issue with Webhook steps processing actions unexpecting, causing errors.

Incident Report for Zapier

Resolved

Our engineering team has rolled users back to a stable version of Webhooks by Zapier to address the recent issues with POST requests.

During the affected period, some data loss may have occurred for workflows where file contents were expected in webhook calls. In these cases, file contents were not returned in a usable format, which prevented downstream steps from receiving the correct file data.

We apologize for any inconvenience this may have caused and will continue to monitor the situation with any future app updates.

If you have questions, please contact our support team: https://zapier.com/app/get-help
Posted Jun 24, 2025 - 13:57 PDT

Monitoring

Our Engineering team is currently in the process of rolling back all users to a previous version of the Webhooks applications.

If you're still having a problem with a Webhooks action step, please feel free to reach out to our support team at here: https://zapier.com/app/get-help
Posted Jun 24, 2025 - 11:04 PDT

Investigating

We've identified an reoccurance of an issue where POST requests sent via WebHooks with Form payload type are returning unexpected content (e.g. ), resulting in missing output and causing dependent steps in Zaps to fail. Separtely, some users have also reported Post requests are sending two responses for a single POST action.

Our engineering team is actively working on a fix. Once deployed, we will automatically replay all affected runs and errored steps.
Posted Jun 24, 2025 - 10:18 PDT
This incident affected: Website and Zaps (Instant Triggers).