Slow loading on Zapier.com
Incident Report for Zapier
Resolved
Zapier.com is loading normally. Tasks that were previously delayed have now completed.

If you're ever seeing anything that doesn't look quite right, please let us know: https://zapier.com/app/contact-us — we're here to help.
Posted Mar 12, 2020 - 23:12 GMT
Update
Zapier.com is loading normally. Some task processing is still catching up, but will return to normal shortly.
Posted Mar 12, 2020 - 22:18 GMT
Monitoring
Zapier.com is returning to normal. Some pages may still be loading slowly. Some Zaps may be processing tasks slower than normally. Thank you for your patience as we resolve this issue.
Posted Mar 12, 2020 - 22:00 GMT
Update
Some pages on Zapier.com are not loading properly. Some Zaps aren't able to work normally right now.
Posted Mar 12, 2020 - 21:39 GMT
Identified
Some pages on Zapier.com are loading slower than normal right now. Zaps continue to send and receive information, but their performance may be delayed. Our team is investigating and will post updates on this status page.
Posted Mar 12, 2020 - 21:21 GMT
This incident affected: Zaps (Instant Triggers, Polling Triggers) and Website, Developer Platform.