"Create New Row in Google Sheets" action populating data in the wrong sheet.
Incident Report for Zapier
Resolved
Between 3:39 UTC and 21:45 UTC yesterday, some customers may have experienced issues with the Google Sheets "Add Row" action, where data was written to the wrong sheet or worksheet. This impacted users with Zaps that wrote to multiple sheets using the same connected account.

We’ve resolved the issue and are currently identifying the affected customers. If your data was impacted, we’ll reach out to you soon.
Posted Oct 07, 2024 - 18:27 PDT
Identified
We believe we have found the root cause of the issue causing data to be sent to other spreadsheets in a user's Google Sheets, and are rolling back the mechanism that caused this.
Posted Oct 07, 2024 - 15:21 PDT
Investigating
We're currently investigating reports of the "Create New Row in Google Sheets" action populating data in the wrong spreadsheet.

We will update here as soon as we have additional information.
Posted Oct 07, 2024 - 14:38 PDT
This incident affected: Website, Developer Platform and Zaps (Instant Triggers, Polling Triggers, Searches & Writes).