Task history log delays
Incident Report for Zapier
Resolved
Task history logs are displaying normally again, and will reflect newly performed tasks, within seconds after they are performed. During this incident, Zaps continued to function normally — only the task history logs were delayed.
Posted Jun 12, 2020 - 11:06 PDT
Investigating
Some task history logs are delayed right now, and may not display the most recent tasks that your Zaps have performed. Otherwise, tasks continue to process normally, but it may be up to an hour before they appear in your task history logs.
Posted Jun 12, 2020 - 09:14 PDT
This incident affected: Website.