LeadScore by Zapier integration is failing with 504 errors

Incident Report for Zapier

Resolved

We have resolved the issue impacting the Lead Score by Zapier integration. Earlier today, all tasks using this integration failed due to an error with the underlying API, following its deprecation of API v1. Access has been restored to the legacy API, and service has returned to normal.
All affected workflows should now be operating as expected.
Thank you for your patience while we worked to resolve this issue. If you continue to experience problems, please contact our support team.
Posted Oct 02, 2025 - 06:50 PDT

Investigating

Our team is investigating errors impacting the Lead Score by Zapier integration due to an API update and we're working with the Madkudu team to resolve this as quickly as possible
Posted Oct 02, 2025 - 03:45 PDT