Users Unable To Publish Drafts – Timeout / Network Error

Incident Report for Zapier

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 11:42 PDT

Monitoring

We have implemented a temporary fix to mitigate these errors on accounts. We hope to have a permanent fix in place shortly.

If you are still experiencing these errors when trying to publish Zap Drafts, please reach out to Zapier Support: https://zapier.com/app/get-help
Posted Jul 02, 2025 - 15:37 PDT

Identified

We're currently investigating an issue where some users are encountering timeout or network errors when attempting to publish their Zaps.

Initial findings suggest the issue is related to a gateway timeout between internal services, which may be preventing draft Zaps from saving or publishing successfully.

This appears to impact a limited number of users and Zaps, but we're continuing to investigate the root cause and monitor for further reports.

We'll share an update as soon as we have more information or mitigation steps.
Posted Jul 02, 2025 - 08:36 PDT
This incident affected: Website.