Facebook Lead Ads integration is currently experiencing issues
Incident Report for Zapier
Resolved
Facebook has resolved the issue that was causing Zaps to see error messages like "Problem creating Webhook Subscription. Insufficient Permission."

Now, you can connect Zapier and Facebook Lead Ads normally. If you saw any errors in the last few days, you can reconnect to Facebook Leads Ads, to prevent these errors from happening in the future: https://zapier.com/app/settings/authorizations

During this issue, Zaps that were already connected with Facebook continued to work normally. This issue only prevented brand new Zaps from connecting with Facebook for the first time.

If you're ever having any trouble connecting with Facebook Lead Ads, our Support team can help to take a closer look: https://zapier.com/app/contact-us
Posted 17 days ago. Mar 07, 2019 - 10:51 PST
Monitoring
Our partners at Facebook have let us know that this is now resolved and we'll continue to monitor the issue closely. Customers should reconnect to Facebook Lead Ads on the Connected Accounts page: https://zapier.com/app/settings/authorizations

If you have any further trouble with this, please reach out at https://zapier.com/app/contact-us
Posted 18 days ago. Mar 07, 2019 - 05:39 PST
Update
Currently, many Zaps are unable to newly connect with Facebook Lead Ads. Zaps that are already connected with Facebook Leads Ads continue to work normally. But when setting up a new Zap, you might see an error: "Problem creating Webhook Subscription. Insufficient Permission. You do not have the necessary permission for the specified Page to perform the requested action."

We're working with our partners at Facebook to investigate the cause of this bug, and bring everything back to normal. You can subscribe to updates, and we'll follow up to confirm when this issue is resolved.
Posted 20 days ago. Mar 04, 2019 - 12:58 PST
Identified
As of 10:00 UTC, Saturday 2nd March, Facebook Lead Ads has been experiencing issues with establishing a webhook subscription for new leads. We are currently researching a solution. Subscribe to receive updates to hear when it's resolved!

When attempting to turn on Zaps, you may receive this error: "Problem creating Webhook Subscription. Insufficient Permission. You do not have the necessary permission for the specified Page to perform the requested action."
Posted 22 days ago. Mar 02, 2019 - 10:16 PST
This incident affected: Apps.