Some tasks are slow to show up in the Zap History
Incident Report for Zapier
Resolved
The issue has been Resolved -- all Zapier.com pages and help articles are accessible. Zap Runs and Tasks continued to process as expected during this incident — no data was lost.

If you continue to see issues, please reach out to our support team here: https://zapier.com/app/get-help.

We appreciate your patience during this incident and apologies for any inconvenience this might have caused.
Posted Jul 26, 2022 - 13:38 PDT
Identified
Hi everyone,

We've identified an issue causing a delay in Zaps and tasks showing up in the Zap History. Users experiencing this issue might see a delay of about 60 minutes between when the Zap runs and when Zap History will be updated.

Zap Runs and tasks continue to run and process as expected -- no data loss is anticipated for this incident. We're currently working to implement a fix to address this issue and will update the StatusPage as soon as we have any updates.

Please reach out to our Support Team if you need anything: https://zapier.com/app/get-help
Posted Jul 26, 2022 - 10:40 PDT
This incident affected: Website.