Erroneous "Held Tasks" For Google Sheets
Incident Report for Zapier
Resolved
Outage has been resolved. We'll be deleting additional held tasks over the next few hours.
Posted 27 days ago. Jul 23, 2019 - 18:26 PDT
Monitoring
We've identified the root issue for the erroneous tasks firing and being held, and are pushing a fix now. We'll be monitoring the issue and updating it accordingly. Thank you for your patience!

Any held tasks stemming from this incident can safely be deleted, as the tasks were generated in error. More on that here: https://zapier.com/help/task-history/#how-do-i-delete-tasks-from-my-task-history
Posted 27 days ago. Jul 23, 2019 - 15:29 PDT
Update
At around 20:40 UTC many Google Sheets "Updated Row" triggers fired erroneously, causing emails to be sent out and tasks to be held, despite no actual rows being updated. Engineering is investigating the cause of why this happened and will be updating this as we know more.

Since these tasks were triggered in error, those held tasks can be safely ignored.
Posted 27 days ago. Jul 23, 2019 - 14:17 PDT
Investigating
At around 20:40 UTC many Google Sheets "Updated Row" triggers fired erroneously, causing emails to be sent out and tasks to be held, despite no actual rows being updated. Engineering is investigating the cause of why this happened and will be updating this as we know more.
Posted 27 days ago. Jul 23, 2019 - 14:04 PDT
This incident affected: Apps.