Typeform issues
Incident Report for Zapier
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 02, 2017 - 11:04 PDT
Identified
We've identified an issue when retrieving form responses from Typeform. We're working with their team to determine a resolution.
Posted 3 months ago. Aug 02, 2017 - 07:25 PDT
This incident affected: Apps.