Delays in Polling Triggers

Incident Report for Zapier

Resolved

We have completed an upgrade of our polling infrastructure. As part of this work, all polling triggers were temporarily paused, which resulted in delays of up to 30 minutes. Polling has now been fully restored, and system performance is back to normal. No data loss is expected as a result of this maintenance.
We apologize for any inconvenience caused and appreciate your patience. If you continue to experience issues with polling Zaps, please contact our support team.
Posted Oct 02, 2025 - 07:03 PDT

Identified

We are currently performing system updates. As a result, polling triggers may experience delays. No data loss is expected.

We will provide more information if the window extends or conditions change.

Thank you for your patience while we complete this update.

Questions? Contact Support: https://zapier.com/app/get-help
Posted Oct 02, 2025 - 05:39 PDT