Delayed task processing for free users
Incident Report for Zapier
Resolved
On July 27th at 16:40 UTC, our team discovered an issue where free Zapier users were seeing trigger delays for their Zaps. Our team has implemented a fix and the issue has been resolved.

Moving forward, all Zaps should trigger as usual and no action is required from free Zapier users.

If you have any further questions about this issue, please reach out to our Support team:

https://zapier.com/help
Posted Jul 27, 2023 - 14:01 PDT
Monitoring
We've recently launched a fix and we're now monitoring the issue. We'll provide an update as soon as a resolution has been reached.

We appreciate your patience while we ensure this issue is fully resolved. If you need any assistance, please reach out to our Support Team: https://zapier.com/app/get-help
Posted Jul 27, 2023 - 10:50 PDT
Investigating
We're currently investigating an issue where free users are experiencing task processing delays on Zapier. Unfortunately, there is no known workaround at this time.

The issue started today at 16:40 UTC. We're actively working on identifying the cause and finding a solution.

We appreciate your patience while we resolve the issue. Please reach out to our Support Team if you need anything:

https://zapier.com/app/get-help
Posted Jul 27, 2023 - 10:43 PDT
This incident affected: Zaps (Instant Triggers, Polling Triggers).