Zap History Delayed Processing
Resolved·Degraded performance

This issue has been resolved, Zap Runs are no back to appearing as normal in Zap History https://zapier.com/app/history, Zaps continued to work normally throughout this incident.

Mon, Sep 27, 2021, 03:16 PM
(4 years ago)
·
Affected components
Updates

Resolved

This issue has been resolved, Zap Runs are no back to appearing as normal in Zap History https://zapier.com/app/history, Zaps continued to work normally throughout this incident.

Mon, Sep 27, 2021, 03:16 PM

Investigating

Zap Runs are currently delayed in being shown on Zap History https://zapier.com/app/history, We will update this status page when this returns to normal. Zaps continue to work normally.

Mon, Sep 27, 2021, 08:51 AM(6 hours earlier)