We are currently investigating an issue leading to task delays.
Incident Report for Zapier
Resolved
All of the remaining incorrect statuses for tasks, have been updated and corrected. Thanks for all of your patience while we worked on the recovery for this incident.

We are closing this now, but as always, if you have any questions, please do not hesitate to send us a message: https://zapier.com/app/contact-us
Posted about 2 months ago. Jun 21, 2019 - 11:20 PDT
Update
The Task History is still displaying incorrect statuses for some tasks from yesterday.

We are continuing to work through the list of tasks with incorrect statuses, and we are over 90% complete at this point.
Posted about 2 months ago. Jun 21, 2019 - 10:36 PDT
Update
The Task History is still displaying incorrect statuses for some tasks from yesterday.

We are continuing to work through the list of tasks with incorrect statuses, so that they can be updated in the Task History. We expect this to be fully complete within a few more hours.
Posted about 2 months ago. Jun 21, 2019 - 08:36 PDT
Update
The Task History is still displaying incorrect statuses for some tasks from earlier today. We are continuing to work through the list of tasks with incorrect statuses, so that they can be updated in the Task History.

All new tasks are running normally, and are showing correct statuses in Task History.
Posted 2 months ago. Jun 20, 2019 - 14:04 PDT
Update
The Task History is still displaying incorrect statuses for some tasks from earlier today.

We are continuing to update those statuses in the Task History, and we will continue to update this incident as we progress.

Beyond that, tasks are running normally at this point, and any new tasks are showing correct statuses in Task History.
Posted 2 months ago. Jun 20, 2019 - 12:22 PDT
Update
The task backlog has been fully processed at this point.

The Task History is still displaying incorrect statuses, for some tasks from today. For example, a task might still be showing as "playing" even though the actions have all been successfully completed. Or a task might not yet be showing in the task history, even though it ran.

We are continuing to update those statuses in the Task History, and we will continue to update this incident as we progress.
Posted 2 months ago. Jun 20, 2019 - 11:21 PDT
Update
We are still processing the backlog of Tasks. The delay is under 5 minutes at this point -- so a task which triggers now will run its first action within 5 minutes from now.

Note that the Task History is currently displaying incorrect statuses, for some tasks from today. For example, a task might still be showing as "playing" even though the actions have all been successfully completed. Or a task might not yet be showing in the task history, even though it ran.

We are starting to update those statuses in the Task History now. We will continue to update this incident as we progress.
Posted 2 months ago. Jun 20, 2019 - 10:25 PDT
Update
We are still processing the backlog of Tasks. The delay is roughly 40 minutes at this point -- so a task which triggers now will run its first action 40 minutes from now.

We will continue to update this incident as we work through the backlog.
Posted 2 months ago. Jun 20, 2019 - 09:20 PDT
Monitoring
We are still processing the backlog of Tasks, and that is approximately 65% complete at this point. We will update this incident again once that is fully complete.

Zaps will still continue to trigger, and action steps will be automatically queued. No data has been lost because of the incident.
Posted 2 months ago. Jun 20, 2019 - 08:19 PDT
Update
We are still processing the Tasks that have been queued because of the incident earlier today. Zaps will still continue to trigger, and action steps will be automatically queued. No data has been lost because of the incident.

We're sorry about the disruption, and appreciate your patience as we work through the backlog of Tasks.
Posted 2 months ago. Jun 20, 2019 - 06:53 PDT
Update
We're continuing to process the Tasks that have been queued because of the incident earlier today, and we hope to get through the Task queue soon. We're sorry about the disruption, and appreciate your patience as we get through the queue. Zaps will continue to receive trigger data, and no data has been lost because of the incident.
Posted 2 months ago. Jun 20, 2019 - 05:58 PDT
Update
Thanks for your patience as we get through the queue of Tasks and process them. We're continuing to work through the queue caused by the incident earlier today. Any affected Zaps should continue to trigger and be processed in the queue, and no data has been lost.

We're really sorry for the delay and disruption this cases. We'll continue to monitor the situation, and post updates here as we get them.
Posted 2 months ago. Jun 20, 2019 - 04:31 PDT
Update
We're seeing a reduction in the queue of Tasks as they're beginning to be played, and we hope to have them all processed soon. We're sorry about the trouble & delay in processing Tasks today, and we thank you for your patience as we're working through them.
Posted 2 months ago. Jun 20, 2019 - 03:27 PDT
Update
We're continuing to process the queue of delayed Tasks caused by the earlier issues. We hope to have processed all remaining Tasks soon, and we'll continue to monitor the situation.
Posted 2 months ago. Jun 20, 2019 - 02:35 PDT
Identified
We have identified the cause of the delay in Tasks processing, and we've addressed the issue. Delayed Tasks are now beginning to be processed, and we hope to be back-to-normal soon. We're sorry for the trouble caused by these delays.

We'll continue to monitor the situation, and we'll post an update here once fully resolved.
Posted 2 months ago. Jun 20, 2019 - 02:01 PDT
Investigating
We are currently investigating this issue.
Posted 2 months ago. Jun 20, 2019 - 00:59 PDT