Act-On Issues
Incident Report for Zapier
Resolved
Everything seems to be back to normal.
Posted 2 months ago. Aug 02, 2019 - 11:16 PDT
Identified
Act-On is currently experiencing issues. Zaps may be delayed until the issue is resolved.
Posted 3 months ago. Jul 22, 2019 - 17:07 PDT
This incident affected: Apps.