The issue regarding user connection to Azure Active Directory via Zapier has been resolved. Users were previously experiencing difficulties in creating new connections or reconnecting existing ones, with an error message stating "Oh, foo. Zapier could not connect to your account. Perhaps you declined access? Or it could be a temporary issue."
We are happy to confirm this issue has been rectified now. Users should be able to establish fresh connections or reconnect their previous ones without encountering the aforementioned error. We'd like to assure our users that all tasks impacted have been dealt with and replayed successfully, and no data was lost during this incident.
If you experience any future issues or difficulties in connecting to Azure Active Directory via Zapier, we encourage you to contact our Support Team via our website: https://zapier.com/app/get-help
Posted 6 days ago. Apr 07, 2025 - 13:53 PDT
Monitoring
Authentications that were previously failing due to the incident have now been fully resolved and are functioning as expected.
We're replaying all Zap runs impacted by the incident to ensure data consistency and integrity.
We appreciate your patience and will continue to provide updates as we progress toward a resolution.
Posted 7 days ago. Apr 07, 2025 - 12:17 PDT
Identified
We've identified an issue that began on April 5th, 2025 at 6:38 PM UTC, affecting users attempting to connect or reconnect to Azure Active Directory via Zapier. Users are unable to create new connections or reconnect existing ones to Azure Active Directory. During connection attempts, users may encounter the following error:
"Oh, foo. Zapier could not connect to your account. Perhaps you declined access? Or it could be a temporary issue." The root cause has been identified, and our team is actively working on implementing a fix. There is no indication of any data loss related to this incident.
We appreciate your patience and will continue to provide updates as we progress toward a resolution.