Task Usage section is currently inaccessible
Incident Report for Zapier
Resolved
On February 18 at around 11:06 PM UTC, our team identified an issue causing the Task Usage section to be inaccessible. We have managed to restore full functionality around 1:00 AM UTC. We are pleased to confirm that Zaps continued to work as expected throughout the incident and that there were no data losses reported.

If you continue to run into an error viewing your task usage, kindly reach out to our Support team at https://zapier.com/app/get-help.
Posted Feb 18, 2024 - 17:32 PST
Monitoring
Our engineering team has deployed a fix for the issue and will continue to monitor it until the Task Usage page is working as expected. Please note there are no reported data losses and Zaps should continue to work as expected in the interim.

If you continue to run into issues with viewing your Task Usage, don't hesitate to reach out to our Support team at https://zapier.com/app/get-help.
Posted Feb 18, 2024 - 16:58 PST
Identified
We're currently experiencing an issue where some users are not able to view the stats in the Task Usage section. The engineering team has already identified the cause of the issue and is working on a resolution. Zaps should still work as expected.

In the meantime, if you need additional help, please don't hesitate to reach out to our Support team at https://zapier.com/app/get-help.
Posted Feb 18, 2024 - 16:39 PST