Slow loading on Zapier.com
Incident Report for Zapier
Resolved
Zapier.com is loading at normal speed again. Sorry about the delays today!

During this incident, Zaps continued to send send receive information normally.

If you're still seeing anything that doesn't look quite right, our support team can help to take a closer look with you: https://zapier.com/app/contact-us
Posted Dec 10, 2019 - 20:06 GMT
Investigating
Some pages on Zapier.com are loading slower than normal right now. Our team is investigating and will post updates on this status page.

Zaps continue to send and receive information normally.
Posted Dec 10, 2019 - 18:17 GMT
This incident affected: Website.