Facebook Leads - New Lead trigger is intermittently missing leads.
Incident Report for Zapier
Resolved
This incident, which previously affected Facebook Lead Ads leads reaching Zapier, has now been fixed.

Meta has confirmed that the backfilling of the missed leads has been completed. Therefore, all leads should now have been processed.

If you have any questions or need additional clarification, you can contact our Support team at https://zapier.com/help.

We appreciate your patience while we worked on resolving this issue. Thank you.
Posted Jul 30, 2024 - 21:24 PDT
Update
Meta has reported that the underlying issue has been resolved and that the missed leads should now be backfilled.

We are still closely monitoring the situation to ensure everything continues to function as expected. If you are noticing any issues with missed leads despite this, we encourage you to reach out to us.
Posted Jul 29, 2024 - 17:54 PDT
Update
We've received reports from users indicating that Meta has started backfilling the leads. You may notice older leads that were missing triggering your Zaps again. Given the volume of missed leads during the incident, it may take some time for all the missing leads to trigger the Zap. If you still notice missing leads, please reach out to our Support Team: https://zapier.com/help
Posted Jul 28, 2024 - 23:52 PDT
Monitoring
Meta expects to resolve this issue soon and will proceed with backfilling missing data by resending lost leads.

Please note that if you have previously manually processed missed leads, you may receive duplicates as Meta backfills. While duplicates may occur, it is a necessary step to ensure all leads are accounted for. We apologize for any additional overhead and/or task usage this may incur for your team.

We continue to monitor the situation and work closely with Meta to ensure a complete resolution.

Thank you for your patience and understanding. If you have any further questions, please feel free to reach out to our Support Team: https://zapier.com/help
Posted Jul 25, 2024 - 14:02 PDT
Update
We've received reports of leads that have not been triggered and have shared this with the Meta team. We will share an update as soon as we have more details.
Posted Jul 24, 2024 - 15:26 PDT
Update
We're seeing customers whose leads haven’t been triggered. If you experience this issue, please submit a support ticket that includes the Zap and the lead IDs along with the timestamps that didn't trigger your Zap.
Posted Jul 24, 2024 - 10:36 PDT
Update
Meta team informed us that the issue should be resolved as of July 23rd, 16:43 UTC. If your Zap(s) continue to trigger intermittently after this time, please reach out to our support team.
Posted Jul 23, 2024 - 17:23 PDT
Update
The Facebook engineering team fixed an “out of memory” issue one day ago, which should reduce the impact of the incident.

However, they’re still working on the mitigation actions and on the root cause identification.

We’re in close contact with them to ensure we get a rapid solution.
Posted Jul 19, 2024 - 06:35 PDT
Update
Meta is currently experiencing an intermittent issue whereby not all leads (e.g. webhooks) are being sent to Zapier. While the majority of leads are still initiating the Trigger, some aren't making it to the Zapier integration.

Our team is actively working with Meta to find a solution. In the meantime, Meta has informed us that leads can still be manually downloaded by following this link: https://www.facebook.com/business/help/734933888443065?id=735435806665862.

We will continue to monitor this issue and work with Meta to resolve this problem.

If you have any further questions, please feel free to reach out to our Support Team: https://zapier.com/help
Posted Jul 17, 2024 - 14:31 PDT
Identified
Meta is currently experiencing an intermittent issue whereby not all leads (e.g. webhooks) are being sent to Zapier. While the majority of leads are still initiating the Trigger, some aren't making it to the Zapier integration.

Our team is actively working with Meta to find a solution.

We will continue to monitor this issue and work with Meta to resolve this problem.

If you have any further questions, please feel free to reach out to our Support Team:

https://zapier.com/help
Posted Jul 16, 2024 - 09:01 PDT