Google Sheets issues
Incident Report for Zapier
Resolved
We've verified that the 429 errors have subsided. Everything is back to normal.
Posted 12 days ago. Mar 13, 2019 - 05:20 PDT
Monitoring
429 errors have subsided. Monitoring Google Sheet further to ensure stability.
Posted 13 days ago. Mar 12, 2019 - 01:49 PDT
Update
Google Sheets is currently experiencing 429 errors. We are investigating and will update as soon as we have more information.
Posted 13 days ago. Mar 11, 2019 - 14:42 PDT
Investigating
Google Sheets is currently experiencing 429 errors. We are investigating and will update as soon as we have more information.
Posted 13 days ago. Mar 11, 2019 - 14:39 PDT
This incident affected: Apps.