Pipedrive issues
Incident Report for Zapier
Resolved
Pipedrive reports everything back to normal.
Posted about 2 months ago. Apr 30, 2018 - 10:17 PDT
Identified
Pipedrive is showing lots of timeouts and errors
Posted about 2 months ago. Apr 30, 2018 - 08:56 PDT
This incident affected: Apps.