Excel integration SSL certificate verification error
Incident Report for Zapier
Resolved
The issue has been Resolved -- Zaps should now be reconnected to Excel without receiving an SSL error. Missed triggers and actions have been successfully replayed. Note that if a Zap was edited after the SSL errors began, unfortunately, we cannot recover that Zap data.

On March 8th, we experienced an issue that caused errors for Zap triggers and actions using our Excel integration due to an SSL certificate validation error.

We’ve resolved this issue and are working to avoid similar certificate incidents in the future.

If you run into any trouble accessing your Zaps, please reach out to our Support Team: https://zapier.com/app/get-help

We appreciate your patience during this incident and apologies for any inconvenience this might have caused.
Posted Mar 08, 2023 - 16:08 PST
Monitoring
We've implemented a fix to address an issue that was causing SSL certificate verification errors for our Excel integration. The fix has now mitigated those impacts, and you should be able to reconnect to Excel as expected.

We are replaying any previously missed Excel tasks and triggers, which should be completed within an hour. Note that if your Zap was edited after the errors began, we are unable to recover that data. After the replay period, Zaps will continue to run and process as usual.

We'll continue monitoring and update this StatusPage within the next 24 hours once we're confident the fix has fully resolved the issue. If you have further questions, please reach out to our Support Team here: https://zapier.com/app/get-help
Posted Mar 08, 2023 - 15:28 PST
Identified
We've identified an issue causing SSL certificate verification errors for Excel triggers and actions. Here are some errors you might see:

- SSL certificate verification errors for Excel triggers and actions.
- Zaps that use Excel becoming disconnected

We're currently working to implement a fix to address this issue and will update the StatusPage in two hours at 17:00 PT / 01:00 UTC.

If you have further questions, please reach out to our Support Team here: https://zapier.com/app/get-help
Posted Mar 08, 2023 - 15:06 PST
Investigating
We're currently experiencing an issue where the Excel integration returns an SSL certificate verification error for Excel triggers and actions.

Users may see this error in:
- error emails for their Excel triggers
- Zap History for Excel actions

We're currently investigating this issue and working on how to mitigate the impacts. We'll update the StatusPage in two hours at 14:43 PT / 20:43 UTC.

We appreciate your patience while we resolve the issue. Please reach out to our Support Team if you need anything: https://zapier.com/app/get-help and you can also reference this Zapier Community thread: https://community.zapier.com/troubleshooting-99/could-not-verify-ssl-certificate-for-excel-21883
Posted Mar 08, 2023 - 12:44 PST
This incident affected: Apps.