Slight Delay in Zaps with Polling Triggers
Incident Report for Zapier
Resolved
The issue has been Resolved -- all Zaps with polling triggers will run without a delay. Zap Runs and Tasks continued to process during this incident — no data was lost.

On April 13th, we identified that our production-polling Redis replicas were not functioning as expected. This anomaly caused an increased load on our primary Redis server. Fortunately, our monitoring systems and redundancy protocols ensured that there was no interruption in service aside from a slight delay. Zapier.com remained fully operational, and all Zaps continued to run and process tasks without any data loss.

Our engineering team has resolved the connectivity issues with the Redis replicas.

If you notice any delays in your Zaps with polling triggers, please reach out to our Support Team: https://zapier.com/app/get-help

We appreciate your patience during this incident and apologies for any inconvenience this might have caused.
Posted Apr 13, 2024 - 12:22 PDT
Monitoring
We've implemented a fix to address an issue that was causing a delay in polling triggers. The fix has now mitigated those impacts and you shouldn't see any delay in your Zaps with polling triggers.

Please note that no data loss has been experienced during this incident.

We'll continue monitoring and update this StatusPage within the next 24 hours once we're confident the fix has fully resolved the issue. If you have further questions, please reach out to our Support Team here: https://zapier.com/app/get-help
Posted Apr 13, 2024 - 10:21 PDT
Investigating
Zaps with polling triggers may be experiencing slight delays. No data loss is anticipated.

We are currently investigating this issue. We will update the StatusPage with further updates.

We appreciate your patience while we resolve the issue. For any concerns related to this incident, you can contact Support here: https://zapier.com/app/get-help
Posted Apr 13, 2024 - 09:33 PDT
This incident affected: Zaps (Polling Triggers).