Some site pages are intermittently slow/inaccessible
Incident Report for Zapier
Resolved
Hi everyone,

The issue has been Resolved -- all Zapier.com pages and help articles are accessible. Zap Runs and Tasks continued to process as expected during this incident — no data was lost.

If you run into any trouble accessing Zapier.com, please reach out to our Support Team: https://zapier.com/app/get-help

We appreciate your patience during this incident and apologies for any inconvenience this might have caused.

Have a great weekend!

Regards,
Zapier Support
Posted Jul 22, 2022 - 05:02 PDT
Monitoring
Hi everyone,

We've implemented a fix to address an issue, and pleasee note that your Zaps continue to run and process as usual -- no impacts or data loss has been experienced during this incident.

We'll continue monitoring and updating this StatusPage once we're confident the fix has fully resolved the issue.

If you have further questions, please reach out to our Support Team here: https://zapier.com/app/get-help

Thank you for your understanding.
Zapier support
Posted Jul 22, 2022 - 03:52 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 22, 2022 - 03:26 PDT
Update
We’ve implemented a fix to mitigate the impact so you should be able to access Zapier.com pages as expected except for some affected articles on our Help page.
Posted Jul 22, 2022 - 02:42 PDT
Investigating
Hi everyone,

We are currently experiencing an issue where our server is under heavy load causing some site pages to slow down or inaccessible.

This incident's impact is only limited to certain site pages. Zaps and triggering events are being processed as normal.
We have identified these issues to have started on Friday 22 July 2022, at 5:35 AM UTC —and is currently under active investigation by our team of engineers.

We apologize for this inconvenience and will keep you up to date as we make progress.

Kindest regards,
Zapier Support
Posted Jul 22, 2022 - 02:17 PDT
This incident affected: Zaps (Instant Triggers, Polling Triggers, Searches & Writes) and Website, Apps, Developer Platform.