The error "(InvalidParameterValueException) when calling the UpdateFunctionCode operation" is affecting private apps and public beta apps
Incident Report for Zapier
Resolved
Our engineering team has successfully completed replaying impacted webhook triggers. This incident is now resolved.

If you continue to see issues, kindly reach out to us at: https://zapier.com/app/get-help
Posted Feb 14, 2022 - 19:55 PST
Update
Our engineering team is currently in the process of replaying webhook triggers (Instant triggers) that were impacted by this error message. Please do not cycle impacted webhook Zaps off and on.

Zaps that use polling triggers have recovered. Users should now see polling triggers operating as expected with a success message.

Actions that failed with this error message should be replayed successfully.
Posted Feb 14, 2022 - 10:35 PST
Update
We are continuing to monitor for any further issues.

- For Zaps that use webhook triggers (Zaps marked as Instant) please do not cycle these Zaps off and on. Our engineering team is currently working to process and resolve webhook triggers that encountered this error.
- Zaps that use polling triggers have recovered. Users should now see polling triggers operating as expected with a success message.
- Actions that failed with this error message should be replayed successfully.
Posted Feb 14, 2022 - 09:21 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2022 - 06:19 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 14, 2022 - 04:31 PST
Identified
Our Engineering team has identified the root cause for this incident and is working on deploying a fix to it as soon as possible.
Posted Feb 14, 2022 - 04:30 PST
Investigating
We're currently investigating an issue where some customers are facing errors on their Zaps, both Triggers and Actions, which stop them from running.

The error is:

An error occurred (InvalidParameterValueException) when calling the UpdateFunctionCode operation: The runtime parameter of nodejs10.x is no longer supported for creating or updating AWS Lambda functions. We recommend you use the new runtime (nodejs14.x) while creating or updating functions.
Posted Feb 14, 2022 - 03:55 PST
This incident affected: Zaps (Instant Triggers, Polling Triggers, Searches & Writes) and Apps.