Object of type datetime is not JSON serializable

Incident Report for Zapier

Resolved

We experienced a brief issue today starting at 6 PM (UTC). Some Zap runs failed with the error "Object of type datetime is not JSON serializable."

Our team quickly identified the problem and implemented a fix. All affected Zap runs have been successfully replayed.

Thank you for your patience as we resolved this. If you have any questions or notice anything unusual, please don’t hesitate to contact us at https://zapier.com/app/get-help.
Posted May 19, 2025 - 13:40 PDT

Monitoring

Our team identified the issue and has implemented a fix. We’re now in the process of replaying any affected Zap runs that encountered the error.

Thank you so much for your patience while we worked through this. If you have any questions or notice anything unusual, feel free to reach out to Zapier Support here: https://zapier.com/app/get-help.
Posted May 19, 2025 - 12:10 PDT

Investigating

We’re currently investigating an issue causing some API responses to fail with the error: Object of type datetime is not JSON serializable.

Please do not hesitate to reach out to us if you experience further issues. Please contact our Support Team here: https://zapier.com/app/get-help
Posted May 19, 2025 - 11:49 PDT
This incident affected: Website.