Delays in tasks and bills
Incident Report for Zapier
Resolved
Zaps are running at normal speed again. Billing pages are loading normally.

During this incident, Zaps were running slower than normal, but continued to send and receive full data.

If you're ever seeing anything that doesn't look quite right, our Support team is here to help: https://zapier.com/app/contact-us
Posted Feb 25, 2020 - 18:01 GMT
Monitoring
Some Zaps are currently experiencing a few minutes of delay in processing tasks. Tasks will still be able to complete, but may be appear as "Pending" for a few minutes.

You may also find some delays in loading billing settings. These delays will be short lived, and should not affect your account's charges, nor the performance of your Zaps.

Our engineering team has identified the issue, implemented a fix, and is monitoring to confirm when everything is back to normal.
Posted Feb 25, 2020 - 17:49 GMT
This incident affected: Zaps (Instant Triggers, Polling Triggers).