Issues adding credit cards and processing payments
Incident Report for Zapier
Resolved
The incident has been resolved and payments with credit card are working again. Thank you for your patience!
Posted Jan 29, 2020 - 09:21 PST
Investigating
We are currently investigating an issue with processing payments on credit cards. Zaps are not affected. We will update this status page with more details when we return to normal.
Posted Jan 29, 2020 - 08:58 PST
This incident affected: Website.