Some Zaps may have missed trigger events
Incident Report for Zapier
Resolved
After extensive monitoring, we are now marking this incident as resolved.

Unfortunately, our investigations revealed that we missed some Zap trigger events during the incident, and we cannot recover this data. We're in the process of directly reaching out to customers who experienced data loss during this incident. Please keep an eye on your inbox for further information.

If you have any questions or continue to experience issues, please reach out to our Support Team: https://zapier.com/app/get-help
Posted Mar 22, 2022 - 16:01 PDT
Update
Our team has replayed the Zap Runs with a “Playing” status in Zap History due to this incident. If you happen to come across any other Zap Runs with a “Playing” status, feel free to replay them following this guidance:

https://zapier.com/help/manage/tasks/replay-failed-tasks-in-zaps

New Zap Runs should be running as expected without any impact from this incident moving forward.

Additionally, our team is still working to understand the impacts of this incident and will communicate any information around data loss early during the week of March 21st.

For questions or additional help, feel free to reach out through our Contact Form here:

https://zapier.com/app/get-help
Posted Mar 18, 2022 - 15:46 PDT
Update
Our engineers have identified areas where failed / Held Zap runs occurred during this incident and we have continued to replay them in batches. If you see held Zap runs or Zap runs that are still stuck in 'Playing' mode in your Zap History that you expected to run by now, you can attempt to replay those safely with no conflict to our team's work to resolve failed tasks.

https://zapier.com/help/manage/tasks/replay-failed-tasks-in-zaps

If still seeing issues with past Zap runs, the team is working to recover these so they can be successfully played. If any data loss is detected after our remaining recovery efforts, we'll be transparent in reporting that to our users.

You can expect new Zap runs to be running regularly without any impact going forward.

For more questions, feel free to contact us: https://zapier.com/app/get-help
Posted Mar 16, 2022 - 18:00 PDT
Monitoring
Hi everyone!

We're happy to share that our engineers have addressed the issue causing the aforementioned issues.

With that, we're in the process of replaying any missed hooks (Zaps with instant triggers).

Please note that some trigger events (both for instant and polling triggers) may not be recovered, although we're doing our best to minimize that.

Thank you so much for your patience. Once the incident has been completed/resolved, we'll be sure to let you know.

Any failed Zap run that is stuck or in playing status, kindly retry a manual replay:

https://zapier.com/help/manage/tasks/replay-failed-tasks-in-zaps

For more questions, feel free to contact us:

https://zapier.com/app/get-help

All the best,
Zapier Support
Posted Mar 16, 2022 - 09:51 PDT
Update
New update:

Our servers are currently under heavy load and this is causing some additional issues.

How this may affect Zapier:

1. Zaps (instant and polling triggers) may not trigger or are delayed
2. Zap runs may be stuck/stopped
3. Creating Zaps or duplicating may return an error

We have a large team of engineers working on this, at this very moment—and fixing it is our highest priority.

Thank you for bearing with us and your patience while we're getting this sorted.

We'll be back with an update soon.
Posted Mar 16, 2022 - 08:41 PDT
Update
Hi again,

A quick update:

Our engineers are still in the process of mitigating the source of the issue.

We're also in the process of attempting to recover missed hooks (trigger events for Zaps with instant triggers) and those will be replayed in smaller batches throughout the day.

Some Zap runs may be delayed in triggering/executing while we're working on this.

We'll keep you informed about the process.

Thank you so much for your patience!
Posted Mar 16, 2022 - 07:34 PDT
Identified
Hi there,

We have identified an issue that may have caused:

1. Zaps with instant & polling triggers failed to trigger
2. Zap runs may have not completed or failed to execute steps

Trigger events between 15 March 2022 14:00 UTC and 16 March 2022 00:30 UTC may have been affected.

This should not have affected, or will affect:

- the zapier.com website
- the Zap editor

We're currently in the process of identifying whether we can recover some missed trigger events—and additional news will be shared. Please accept our sincerest apologies for this inconvenience.

For any failed Zap runs, kindly check if these can be manually replayed:

https://zapier.com/help/manage/tasks/replay-failed-tasks-in-zaps

We'll be in touch.

Kindest regards,
Zapier support
Posted Mar 16, 2022 - 04:49 PDT
This incident affected: Zaps (Instant Triggers, Polling Triggers, Searches & Writes).