Jotform
Incident Report for Zapier
Resolved
JotForm has returned to normal, and is now sending new form submissions to Zapier normally.

If you have any questions about how your Zaps are working, our support team can help to take a closer look: https://zapier.com/app/contact-us
Posted 14 days ago. Jul 09, 2019 - 12:19 PDT
Monitoring
Some users are reporting that JotForm form submissions from earlier today are coming through now. We are monitoring the situation and will close this issue once we have confirmed it has been resolved.
Posted 14 days ago. Jul 08, 2019 - 19:29 PDT
Investigating
Beginning around 21:30 UTC on July 8th 2019, some Jotform users have reported that new form responses are not triggering Zaps. Jotform has been made aware of the issue and are investigating.
Posted 14 days ago. Jul 08, 2019 - 18:54 PDT
This incident affected: Apps.