Zap History Page not displaying any Run logs (Zaps are still running!)
Incident Report for Zapier
Resolved
This incident has been resolved. Thank you for your patience as we looked into this!
Posted Dec 09, 2021 - 12:27 PST
Monitoring
The rollback has been completed and the History Page should be back to normal function.

We are continuing to monitor the situation, and please reach out via the Contact Form (https://zapier.com/app/contact-us) if you have any more trouble loading the Zap History Page.
Posted Dec 09, 2021 - 10:32 PST
Identified
We have identified an issue where a recent deploy caused the Zap History Page (https://zapier.com/app/history) to no longer display Zap Runs.

Please rest assured all Zaps are still running in the background; this is purely a webpage display issue.

A rollback has been initiated and we will update you when things have returned to normal operation.

You can track the activity of your Zaps via the Task Usage Page (https://zapier.com/app/history/usage) to confirm Runs are still occurring.
Posted Dec 09, 2021 - 10:25 PST
This incident affected: Website.