Zap runs are slowed down or delayed
Incident Report for Zapier
Resolved
We have identified and implemented a fix for an issue that caused Zap execution to be delayed. After monitoring the situation, we are now marking this incident as resolved. You should see Zaps running as expected. If you continue to see issues, please reach out to our support team here: https://zapier.com/app/get-help.
Posted Mar 15, 2022 - 19:19 PDT
Investigating
We have seen a spike in Zap runs being slowed down or delayed again. Any possibility of data loss is currently being investigated.
Posted Mar 15, 2022 - 13:41 PDT
Monitoring
A fix has been implemented and we're continuing to monitor the results. Users should see Zaps returning to their normal behavior.
Posted Mar 15, 2022 - 10:19 PDT
Investigating
We're currently investigating an issue where some Zap runs are slowed down or delayed. Customers may experience some Zaps not triggering or running as expected. There is no expected data loss at this time.

We will update this status page with more details on how things will return to normal.
Posted Mar 15, 2022 - 08:09 PDT
This incident affected: Zaps (Instant Triggers, Polling Triggers, Searches & Writes).