Some users might be seeing an error when turning a Zap on from the 'My Zaps' page
Incident Report for Zapier
Resolved
The issue has been resolved and users should no longer see errors when turning their Zaps on from the 'My Zaps' page. There is no data loss and operations are back to normal.

We appreciate your patience during this incident and apologies for any inconvenience this might have caused.
Posted Oct 06, 2022 - 19:04 PDT
Monitoring
A fix has been implemented that should allow affected users to turn on their Zaps from the ‘My Zaps Page’ without errors. Our internal tests have shown so far that this issue is now fixed.

We’re now in the monitoring phase and we will update the status page again as soon as all final checks are completed.
Posted Oct 06, 2022 - 18:50 PDT
Identified
We have identified the root cause of the issue and are now working on fix.
Posted Oct 06, 2022 - 17:57 PDT
Investigating
When turning on a Zap from the 'My Zaps' page, a user might see this error when doing so:

[Error turning Zap on: enable_zap_version() missing 1 required positional argument: 'customuser_id']

We are now in the investigation process. We are searching for the update that might be causing this so we can roll it back.

We will continue to update affected users as we make progress. There is no workaround for this issue at this time.

We appreciate your patience while we resolve the issue. Please reach out to our Support Team if you need anything:
https://zapier.com/app/get-help
Posted Oct 06, 2022 - 17:43 PDT
This incident affected: Website.