Editor not allowing edits on individual Zap steps
Incident Report for Zapier
Resolved
Our team has identified the issue and implemented a fix. This problem should no longer persist.

If you're unable to edit individual steps, please try clearing your browser's cache OR use a different browser.

Should you find that you're still running into this issue, please reach out to our Support team:

https://zapier.com/app/get-help
Posted Sep 25, 2023 - 15:23 PDT
Investigating
Our team has recently been made aware of an issue causing users to not be able to make edits to some steps in the Zap Editor. We're currently investigating and will provide an update as soon as we can.

In the meantime, if you're unable to edit individual steps, please try clearing your browser's cache OR use a different browser.

If you need more immediate assistance, please reach out to our Support team:

https://zapier.com/app/get-help
Posted Sep 25, 2023 - 12:49 PDT
This incident affected: Website.