We are currently investigating an issue leading to task delays.
Incident Report for Zapier
Resolved
This incident has been resolved.
Posted 24 days ago. May 01, 2019 - 05:19 PDT
Investigating
We are currently investigating this issue.
Posted 24 days ago. May 01, 2019 - 04:43 PDT