Zap history not loading new Zap runs, Zaps are working
Incident Report for Zapier
Resolved
We have identified and addressed the cause, and the Zap history is now up to speed and functioning normally. Zap runs should now be reflected in your Zap History.
Posted May 08, 2024 - 16:49 PDT
Identified
We've identified an issue with hitting limits in updating our history database leading to increased delay for tasks to show up on the website - tasks themselves are not effected.
Posted May 08, 2024 - 15:37 PDT
Investigating
We are currently investigating an issue with our Zap history feature. As of 7:10PM UTC, new Zap Runs are being processed as usual, but they are not appearing in the Zap history.
To clarify the user impact, all tasks and automations are still functioning as expected; the only difference is that new actions are not being recorded in your Zap history log.
We are actively working to identify and address the cause of this issue. Your existing operations should not be affected during this time and you can continue to use Zapier as normal for your tasks and workflow automations.
Thank you for your patience as we work on resolving this. If you need further assistance, feel free to reach out to our Support Team at https://zapier.com/app/get-help.
Posted May 08, 2024 - 13:11 PDT