Zap Trigger Delays
Incident Report for Zapier
Resolved
Earlier today, we experienced trigger delays of approximately 7-8 minutes from 14:50 UTC to 15:35 UTC. The issue was fully resolved at 15:35 UTC, and our monitoring period was completed at 17:41 UTC. We have attempted to review and process any Zaps that were affected by this that didn’t run.

All Zaps are now functioning properly. Some runs may not have run properly in the timeframe or triggered at all. We would ask if our users have noticed any missed runs during this window of time to reach out to please contact our support team here: https://zapier.com/app/get-help.
Posted Jun 14, 2024 - 12:43 PDT
Monitoring
We are currently monitoring a situation that occurred earlier today. There were trigger delays of approximately 7-8 minutes starting at 14:50 UTC and it appears that normalcy was regained around 15:35 UTC. Our previous status message did not accurately reflect these timings.
During this incident, no data was lost and all your Zaps should be functioning properly now, despite the short delay experienced earlier.
We apologize for any inconvenience caused and appreciate your understanding. We will continue to keep a close watch and update this page as necessary.
For additional support or any further queries, please contact our support team here: https://zapier.com/app/get-help.
Posted Jun 14, 2024 - 09:09 PDT
Investigating
We are currently investigating an issue that began around 7:50am UTC today. This issue is causing delays of roughly 3 minutes with Zap triggers, including both instant and polling triggers.

Users may experience delays in executing their Zaps.

Our teams are working to resolve this as quickly as possible. We will post updates here as more information becomes available.

Meanwhile, if you need assistance, our Support Team is ready to help. Please contact them at https://zapier.com/app/get-help.
Posted Jun 14, 2024 - 08:33 PDT