Some tasks are slow to show up in the Zap History
Incident Report for Zapier
Resolved
The issue has been Resolved -- Task processing has returned to its normal speed. No data was lost.

If you run into any continued issues with tasks processing slowly, or notice Zap Runs stuck in "Playing" status, please contact our support team:

https://zapier.com/app/get-help

We appreciate your patience during this incident and apologize for any inconvenience this might have caused.
Posted Dec 08, 2022 - 14:22 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 08, 2022 - 14:20 PST
Monitoring
A fix has been implemented and we're monitoring the situation. There should no longer be a delay in Zap runs showing in the Zap history.

Zap Runs and tasks continue to run and process as expected -- no data loss is anticipated for this incident.

Please reach out to our Support Team if you need anything: https://zapier.com/app/get-help
Posted Dec 08, 2022 - 14:19 PST
Identified
We're currently experiencing an issue where there's a delay in Zap runs showing in the Zap history. This started around 20:45 UTC. Zap runs and tasks will continue to run and process as expected but there is a delay in them appearing in the Zap history. No data loss is anticipated for this incident.

We've identified the cause of this issue. We're currently working to implement a fix to address this issue and will update the StatusPage when this is done

We appreciate your patience while we resolve the issue. Please reach out to our Support Team if you need anything: https://zapier.com/app/get-help
Posted Dec 08, 2022 - 14:12 PST
This incident affected: Zaps (Instant Triggers, Polling Triggers, Searches & Writes) and Website, Apps, Developer Platform.