Task History pages not loading for some users
Incident Report for Zapier
Resolved
The issue has been resolved and Task History pages are loading normally now for all users.
Posted Apr 03, 2020 - 04:08 PDT
Investigating
We are currently investigating an issue where Task History pages are not loading for some users. Tasks themselves are not affected, just the loading of the pages. We will post updates here as we have them!
Posted Apr 03, 2020 - 01:08 PDT
This incident affected: Website.