Microsoft Defender Blocking Zapier Password Reset Emails
Incident Report for Zapier
Resolved
Our engineering team has resolved the issue with reset password links not functioning properly if the email was scanned by Microsoft Defender.

The reset password link will now remain valid as long as the request to reset your password is less than 24 hours old when the email is delivered.
Posted Feb 14, 2025 - 10:48 PST
Update
Our engineering team has resolved the issue with reset password links not functioning properly. The reset password link will now remain valid as long as the request to reset your password is less than 24 hours old when the email is delivered.

However, we're still investigating the issue where Microsoft Defender is blocking emails from security@mail.zapier.com. If you are affected, please check your Microsoft Defender admin settings to ensure that security@mail.zapier.com is marked as a safe sender.

In the meantime, if you are not receiving the password reset email, please ask your email admin to try the following steps:

1. Log into the Admin Office account: https://security.microsoft.com/quarantine
2. Click the menu on the left > Email & Collaboration > Review
3. Select the Zapier password reset email “Under Review” and press “Release Email”
4. This should return the reset email back to your inbox
5. If the reset link is expired, please try sending another email: https://zapier.com/app/login/forgot
6. You may also need to click "Trust Sender" and "Show Blocked Content" to get the link to work

We appreciate your patience as we continue working on this. Please reach out to our Support team if you need further assistance: https://zapier.com/app/get-help
Posted Feb 03, 2025 - 08:46 PST
Identified
We have identified the issue causing Microsoft Defender to block emails from security@mail.zapier.com. In some cases, even when the email is delivered, links within the email may not function properly.

Some customers have been able to log in to their accounts using Google, Facebook, or Microsoft login options as a workaround.

Posted Jan 31, 2025 - 08:26 PST
Investigating
We are currently investigating an issue where Microsoft Defender is blocking emails from security@mail.zapier.com. In some cases, even when the email is delivered, links within the email may not function properly.

If you are experiencing this issue, please check your Microsoft Defender admin settings and ensure that security@mail.zapier.com is marked as a safe sender or allowed. Additionally, verify that the emails are not being quarantined or filtered. If you do not have access to these settings, we recommend reaching out to your IT department to review and update them accordingly.

For guidance on handling false positives in Microsoft Defender, please refer to the following guide:

https://learn.microsoft.com/en-us/defender-office-365/step-by-step-guides/how-to-handle-false-positives-in-microsoft-defender-for-office-365

We appreciate your patience while we resolve the issue. Please reach out to our Support Team if you need anything:

https://zapier.com/app/get-help
Posted Jan 31, 2025 - 07:52 PST