Delay showing new Zap Runs in the Zap History

Incident Report for Zapier

Resolved

The issue has been resolved - Zap Runs are appearing as normal.
Posted 2 years ago. Oct 05, 2023 - 08:20 PDT

Monitoring

A fix has been implemented and we're now monitoring the results. We'll update this page within 24 hours with more information.

If you need immediate assistance, please reach out to our Support team:

https://zapier.com/app/get-help
Posted 2 years ago. Oct 04, 2023 - 07:37 PDT

Investigating

Our team has recently discovered an issue causing Zap Runs to appear up to 10 minutes after running. We're actively investingating this issue and will provide an update as soon as we can.

If you need immediate assistance, please reach out to our Support team:

https://zapier.com/app/get-help
Posted 2 years ago. Oct 04, 2023 - 07:33 PDT
This incident affected: Website.