Delayed hooks for Google Apps

Incident Report for Zapier

Resolved

We’ve identified that the delays affecting webhooks for Google Apps were part of a broader issue. That larger issue is being tracked here: https://zapier.statuspage.io/incidents/c2q9td1yrglp. Thank you for your patience.
Posted Jul 18, 2025 - 10:41 PDT

Investigating

We are investigating an issue with hooks being delayed for Google apps.

If you're running into this issue, please reach out to our Support team: https://zapier.com/app/get-help
Posted Jul 18, 2025 - 09:06 PDT