Failed to Fetch Needs error on the Zap editor
Incident Report for Zapier
Resolved
The issue has been resolved, and users should no longer experience the 'Failed to fetch needs' error. The incident started at 14:56 UTC and was resolved by 16:55 UTC.

We appreciate your patience during this incident and apologize for any inconvenience it may have caused. If you encounter any further issues, please reach out to our Support Team: https://zapier.com/app/get-help
Posted May 03, 2023 - 09:07 PDT
Identified
We've identified an issue causing users to experience an error message in the Zap editor: "Failed to fetch needs for step_GEN_1683123740446." Unfortunately, there is no known workaround at this time.

Our team is actively working on resolving this issue. We will provide updates on the estimated resolution time and expected behavior after the fix as soon as we have more information.

We appreciate your patience while we work to resolve this issue. If you need assistance or have any questions, please reach out to our Support Team: https://zapier.com/app/get-help
Posted May 03, 2023 - 08:12 PDT
This incident affected: Website.