Tasks processing is currently experiencing a delay
Incident Report for Zapier
Resolved
The previous delay of tasks are all caught up now. Thanks for your patience.
Posted Nov 18, 2019 - 17:52 PST
Investigating
Some users are reporting a slow down of task processing. Users may also experience a delay in accessing the Task History. We're currently investigating the cause, subscribe above for updates.
Posted Nov 18, 2019 - 17:06 PST
This incident affected: Zaps (Searches & Writes).