Delay in polling-triggered Zaps triggering

Incident Report for Zapier

Resolved

The issue causing a delay of approximately 16–30 seconds for polling-triggered Zaps has been resolved. Zaps are now running without delay.

On September 19, our systems experienced a temporary issue that caused polling-triggered Zaps to run with a short delay. Our engineering team identified and implemented a fix, and we’ve confirmed that systems are back to normal.

We’ll continue monitoring to ensure consistent performance and prevent future recurrences.

Thank you for your patience.
Posted Sep 19, 2025 - 10:10 PDT

Monitoring

A fix has been implemented by our engineering team for the issue that caused a minor polling delay of approximately 16–30 seconds for Zaps with polling trigger types. Zaps are now running as expected. No data loss has occurred.

We’ll continue to closely monitor performance and post updates as they become available.

If you notice anything unusual, please contact Support at https://zapier.com/app/get-help.
Posted Sep 19, 2025 - 09:17 PDT

Investigating

We're currently investigating an incident where polling-triggered Zaps may be experience a delay in triggering.

We'll update this StatusPage once we've identified the issue and begin working to implement a fix.

We appreciate your patience while we resolve the issue. Please reach out to our Support Team if you need anything: https://zapier.com/app/get-help
Posted Sep 19, 2025 - 08:20 PDT
This incident affected: Website, Apps, Developer Platform and Zaps (Instant Triggers, Polling Triggers, Searches & Writes).