Task History Lag - Tasks not appearing as expected
Incident Report for Zapier
Resolved
On February 13th, 2023 between 4:41pm UTC and 8:47pm UTC, our team discovered an issue which resulted in tasks appearing in the Zap History roughly an hour after a Zap Run. Users would likely have seen a Zap trigger and run, but the Task did not appear immediately in the Zap History.

This issue has since been resolved by our team.

If you run into any further troubles locating Zap Runs in your Zap History, please reach out to our Support Team:

https://zapier.com/app/get-help

We appreciate your patience during this incident and apologies for any inconvenience this might have caused.
Posted Feb 13, 2023 - 13:32 PST
Monitoring
We've implemented a fix to address an issue that was causing delays in Tasks appearing within the Zap History.

Please note that Zap Runs and Actions will continue to function as intended. There was no impact to Triggered Zaps.

We'll continue monitoring and update this StatusPage within then next 24 hours once we're confident the fix has fully resolved the issue. If you have further questions, please reach out to our Support Team here:

https://zapier.com/app/get-help
Posted Feb 13, 2023 - 10:05 PST
Update
We are continuing to investigate this issue.
Posted Feb 13, 2023 - 09:07 PST
Investigating
We're currently investigating an issue affecting Zap History. Users may see a delay in tasks showing within the Zap History of up to one hour. Zap Runs and Actions will continue to function as intended although they may not be visible in the Zap History.

We appreciate your patience while we resolve the issue. Please reach out to our Support Team if you need anything: https://zapier.com/app/get-help
Posted Feb 13, 2023 - 08:59 PST
This incident affected: Website.