Google Sheets triggers may be delayed
Incident Report for Zapier
Resolved
Zapier users may have noticed difficulties regarding our integration with Google Sheets. We observed fewer webhooks from Google Sheets than anticipated, resulting in potentially delayed operations for those who leverage Google Sheets as a trigger within their Zaps.

The incident has been rectified. As of our latest checks, Google Sheets-triggered Zaps should now operate as normal without additional delay.

For those who may continue to experience issues or have queries, our support team is always available and can be contacted via: https://zapier.com/app/get-help

Your understanding and patience is greatly appreciated. We apologize for any inconvenience caused by this incident.
Posted Jul 13, 2024 - 04:44 PDT
Monitoring
Our engineering team is seeing signs of recovery and will continue to monitor the issue to confirm it's fully resolved.

If you believe your Zaps might be affected or if you have any other concerns, don't hesitate to contact our Support team at https://zapier.com/app/get-help.
Posted Jul 12, 2024 - 20:09 PDT
Identified
We have identified the issue causing delayed Google Sheets triggers and are working on a fix. We will share an update as soon as the issue is resolved.
Posted Jul 12, 2024 - 16:17 PDT
Investigating
We are currently investigating an issue with Zapier's integration with Google Sheets. It appears that we are receiving fewer webhooks from Google Sheets than expected. As a result, some users may experience delays with their Zaps that use Google Sheets as a trigger.

Our team is working diligently to investigate and resolve this issue. We will provide updates here as we learn more.

In the meantime, if you have any queries or concerns, please do not hesitate to get in touch with our support team: https://zapier.com/app/get-help.
Posted Jul 12, 2024 - 09:07 PDT