Task processing is delayed
Incident Report for Zapier
Resolved
Zaps are again running as fast as they normally should.

If you're ever seeing tasks that don't work the way you expect, please let us know: https://zapier.com/app/contact-us
Posted 2 months ago. Jul 31, 2019 - 08:23 PDT
Update
We are working through playing the delayed tasks now and will update here once we're all caught up. Thanks for your patience!
Posted 2 months ago. Jul 31, 2019 - 07:57 PDT
Identified
Right now, Zaps are not working as fast as we normally expect. New information is still being received from your other apps, but the action steps are not yet happening. Some tasks may appear to be stuck “Playing”. We will update this status page with more details on how things will return to normal.
Posted 2 months ago. Jul 31, 2019 - 07:36 PDT
This incident affected: Zaps (Instant Triggers, Polling Triggers).